stephenbrooks.orgForumMuon1Generalwine 1.5.11 and dpad
Username: Password:
Search site:
Subscribe to thread via RSS
[OCAU] badger
2012-10-05 03:52:00
I have a new box running fedora 17. I've been running dpad under wine (v0.9.36) with no problems on an older box (RHEL 4) with "wine muon1.exe -c".

When I do the same (now wine version 1.5.11) on the new box it works fine up to the point where it actually starts the simulations after the Line "Starting", then stops there at t=1.16ns and does no more work.  If a save file is present, it loads it and jumps to the time in the save file eg t=1600ns then stops.  CPU use jumps up during the setup phase, then goes to 0 .

Wine works fine for other stuff like superpi.

Anyone got any ideas? 
[Edited by [OCAU] badger at 2012-10-05 03:55:57]
[OCAU] badger
2012-10-05 06:23:42
Upgraded/reinstalled wine, now at 1.5.13, still same issues...
Stephen Brooks
2012-10-05 16:38:05
A colleague using Wine 1.3.28 here doesn't have a problem.  Have you tried running it single-threaded?  (multi-thread bugs often stop weirdly in the middle of things)

Another thing you might try is setting "Sleep on battery" to "N" in config.txt in case a weird bug I once had with Wine thinking a desktop was on battery has come back.
[OCAU] badger
2012-10-08 01:07:18
Was "sleep on battery", I didn't even think of changing that on a desktop.  Working away on 4 cores of a i5 now, should help out a bit Perhaps some more stuff in the FAQ about running it under wine would help?  I can't seem to run it from another machine (using Putty) as it wants a display variable set (even the commandline or background versions).

While I'm complaining, all my processes are trying to download a samplefile called :
linac900ext6xc2_nosample_100.bin which doesn't exist.  I'm not sure why the "nosample" is in there, doesn't seem to match the normal format.
I found in "linac900ext6xc2_nosample.txt in the lattices directory and renamed it without the "nosample" and it downloaded it again (because it is in latticelist.txt?  I've removed the entry from latticelist.txt, seems ok now...

Zerberus
2012-10-08 06:03:15
Don't do that, the _nosample lattice is a genuine one.  It's an older lattice that's now re-run without samplefiles by purpose (as the name tells).  It is absolutely correct that the samplefile doesn't exist!

Maybe the next client version will skip over trying to download a samplefile if the name of the lattice ends with _nosample.


[Edited by Zerberus at 2012-10-08 06:04:06]
Stephen Brooks
2012-10-08 15:38:12
Was "sleep on battery", I didn't even think of changing that on a desktop.

Yes, sorry, I also realise that this is an issue under Wine on desktops in the current v4.45 release.  It's fixed in the development code.  Hoping to push out another overdue maintenance release before year end.

Maybe the next client version will skip over trying to download a samplefile if the name of the lattice ends with _nosample.

Yes, at the moment it's a server-side hack.  Might do this.
[OCAU] badger
2012-10-10 05:29:01
Ah, that makes sense.  I was annoyed at the 5-10 s delays when doing short runs while it waited for the nonexistent file to download, however I've realised the delays were due to the other problem where Stephen's server was banning my IP, and it is less than a second now.

I would think an easier solution would be to have a sample file that is empty, that way it won't complain about not being able to download it...
Stephen Brooks
2012-10-10 15:43:17
I didn't think of making an empty file, though I'm not sure if Muon1 would crash if given an empty one.  To test it, set your client to just do the _nosample lattice for a while, downloading a specially-named empty sample file, by changing these two lines in config.txt:

Preferred lattices (comma-separated list or 'none'): Linac900Ext6Xc2_nosample
Sample file URL (.bin allowed): http://stephenbrooks.org/muon1/samplefiles/{lattice}_badgers.bin
Zerberus
2012-10-10 16:04:09
So far it looks like it is happily accepting it.


Loading 'samplefiles\Linac900Ext6Xc2_nosample.txt'... OK (0 results)
Stephen Brooks
2012-10-10 16:19:14
OK, fingers crossed and rolling it out to the rest of the project (you can set the sample URL back to _100 instead of _badgers now).
Zerberus
2012-10-10 19:02:04
Even after some hours it was still alive.  Should explain the apparent rush of _nosample results from my client, lol.
: contact : - - -
E-mail: sbstrudel characterstephenbrooks.org
Yahoo: scrutney_mallard
Jabber: stephenbrooksstrudel characterjabber.org
Twitter: stephenjbrooks

Site has had 16216808 accesses.