stephenbrooks.orgForumMuon1GeneralLinac900Ext8Xc2 has passed 7Xc2
Username: Password:
Search site:
Subscribe to thread via RSS
Stephen Brooks
2013-09-04 15:49:19
In the last week, the 8Xc2 optimisation has beaten the record of 4.142452% set by 7Xc2. This is significant because this is now the highest linac yield simulated with v4.45 or above. The only one that beats it is a v4.44d result in 6tc2, but v4.44x and below had some random jitter coming from the RF cavity model.
Zerberus
2013-09-04 17:33:06
Sounds great.

Unfortunately, 4.46 still hangs on some lattices and sometimes crashes (some minutes after start, on ALL lattices, even in background mode).
Stephen Brooks
2013-09-05 15:01:36
I wonder what's odd about your computer?  Because it's running fine here under Windows 7 Pro/64-bit on an Intel Xeon, and my AMD at home, plus there are over a million returned v4.46 results from other users.

I imagine you've already tried deleting everything and reinstalling fresh?  Also Win7 is sometimes funny about putting stuff in restricted folders (e.g. I had great trouble putting it in Program Files\Muon1 because it didn't have write permissions initially).
Zerberus
2013-09-13 18:01:28
Odd?  As for the graphics issues, I should mention I'm on 1920x1080 120Hz.  The rest is pretty normal: 6Core AMD Phenom II 1090T, 32GiB RAM, 2x2TB storage, Windows 7 Ultimate SP1.

Just a guess: I don't run on automatic cores, but have fixed the core selection.  Could that cause a problem?

Edit: Running two Muons from separate directories.
[Edited by Zerberus at 2013-09-13 18:02:25]
Stephen Brooks
2013-09-16 18:03:11
I've had a report of an intermittent crash from another user now so might put up a debug version.

I don't think setting the number of cores manually should be a problem.  Did you try running commandline?  That would at least tell you at what stage the crash occurs.  Also you might want to turn autosave off to see if it's crashing when it tries to save for some reason (unwriteable file?)
havardma
2013-09-27 09:42:19
I've seen some crashes when running 4.46 using backgroundmode.  If it happens it also happens every time I try to continue with that auto.sav file.

I have a couple of those auto.sav files lying around that I can send you if they may help debugging the problem?
Stephen Brooks
2013-09-27 17:07:16
OK, might be useful, send them to my sb@stephenbrooks.org address.
Zerberus
2013-09-28 14:47:06
Interesting fact, may be related: Since I changed from sending via FTP to sending via HTTP, I had no more crashes in background mode.  Might be related...

Hope we'll find the issue with the hangs in graphics mode someday.  Although I said earlier the hangs occur with older lattices, it occasionally hangs with new ones, too.  However, how to debug hangs?
Zerberus
2013-09-29 17:22:34
Spoke too soon, had a crash again yesterday.
Stephen Brooks
2013-09-30 14:33:43
Still no crashes here, at all, ever.  Here is my config file for v4.46:
Resolution (XxY, 'auto' or 'span'): auto
Priority for background running ([N]ormal, [L]ow, [B]ackground): L
Threads (number or 'auto'): auto
Auto-send results ([Y]es, [N]o): Y
Results upload method ('FTP' or 'HTTP'): HTTP
Use proxy server for HTTP downloads ('auto', 'no' or server,port): wwwcache.rl.ac.uk,8080
Auto-save interval (seconds; 0 for no save): 240
Update lattice files from web every N hours (0=don't): 12
Download sample results file after a number of hours (0=don't, min.  6): 24
Sample file behaviour - use [L]atest only, or [A]ccumulate: L
Sample file URL (.bin allowed): http://stephenbrooks.org/muon1/samplefiles/{lattice}_100.bin
Results file maximum size before pruning (MB, 0 to disable): 50
Keep mode ([B]est results, [F]irst, [L]atest or [R]andom): B
Keep proportion (%): 50
Removed results store (or 'none'): results_removed.dat
Sleep on battery power: Y
CPU throttle (%): 100
Preferred lattices (comma-separated list or 'none'): none
Particles per extra thread (limits threading overhead): 35
Rechecks for best-so-far results (min.  5): 5
FTP command call: ftp -script.ftp
Use passive (PASV) mode for FTP transfers: N
Use old FTP calling method (as pre-v4.34; can hang, but more compatible with ZoneAlarm): N
TrialType ratios: Random=0;Mutate=3;Crossover=3;Interpolate=3;Extrapolate=3;MuSpherical=3;MuOne=3;Extreme=1;LocalGrad=3;TopoSmooth=1;CellDouble=1;CellDelete=1;CellCommute=1;
Delete sample files for old lattices: Y
Stephen Brooks
2013-10-02 15:12:45
I just produced this debug-mode executable that you can run instead, to see if it produces a box with line numbers, error info, etc.

There's an optimisation switch on the LCC compiler that makes the program faster but on older CPU architectures it caused some instability.  I thought we'd got past that, though it's another thing to try.
: contact : - - -
E-mail: sbstrudel characterstephenbrooks.org
Yahoo: scrutney_mallard
Jabber: stephenbrooksstrudel characterjabber.org
Twitter: stephenjbrooks

Site has had 16217678 accesses.