stephenbrooks.orgForumMuon1Bug ReportsStats seem to have stoped working
Username: Password:
Search site:
Subscribe to thread via RSS
2015-03-18 05:31:44
I'm uploading work but I haven't seen an increase in my stats for a day or two now. 
20150317-003009 50 results sent to
20150317-060216 32 results sent to
20150317-153509 50 results sent to
20150317-231012 50 results sent to
20150318-052901 31 results sent to
Stephen Brooks
2015-03-18 15:56:26
Thanks for letting me know.  I think the USB hard drive just came un-mounted, hopefully they should be back up within an hour.
2015-03-19 05:29:25
Thanks, it all seems to be working now
2015-03-23 08:22:22
No, it's stopped again
Stephen Brooks
2015-03-24 20:51:28
It's now working.  Looking at the logs, it seems there was a run-on instance of the stats generator from Saturday that didn't terminate, but it got killed after 48 hours.
2015-08-09 16:25:32
i uploaded some results last day, but stats `paid` me 323k negativ score!  (1core Ht,almost 4weeks of running)
What could be wrong ?

[Edited by morgan at 2015-08-09 16:26:46]
Stephen Brooks
2015-08-10 17:26:43
You can try pasting the end of results.dat (not the whole thing, just the results you wanted to send) into results.txt and running manualsend.bat.

The stats went off over the weekend, running again now.  Unless somehow your results are what is causing the glitch...
2015-08-10 19:02:22
Probably unrelated...

My stats just lost 963 points a couple of hours after the main results all got credited from the downtime.
Had a complete power cut this morning so am guessing somehow a result got duplicated. 
Is the result posted to the results.txt file before an auto.sav file gets deleted ?
Any other explanation if not that ?
Stephen Brooks
2015-08-10 20:35:21
The overall total graph of results is not really showing a dent, so I don't think there's something hugely wrong overall.  But you may want to try re-sending the last few results out of results.dat if you think it's got it wrong.

Occasionally (if it's been disrupted by a power cut or other outage) I've seen the stats script not notice repeated results until a later addition to that particular file, which can trigger a re-indexing.  Re-sending should determine if they really are duplicates.
2015-08-17 07:46:11
Sorry Stephen, but it's broken again.
last updated 2015-Aug-14; 13:07 UTC
Stephen Brooks
2015-08-17 17:24:08
That was a hardware error!  The external USB drive enclosure had stopped being recognised by my workstation.  But thanks for pointing it out.

[edit] Might take a few hours to count through the backlog.

[edit2] Took a while but it's back up.
Stephen Brooks
2015-08-19 19:16:31
Recent errors might be because the 2TB disk in the enclosure has now died.  The 320GB nightly mirror (the original Muon1 disk from ages ago) is fine.  I also have two network backups.  I think I'll try and run it off the small disk until a replacement arrives.

Obviously this means I've lost the last ~12 hours of results, but I'm going to wait until the new (old) disk is updating properly before saying people should re-send.

Just ordered a 2TB replacement, this time from HGST not Seagate.  When it arrives, there'll be some downtime to copy everything over, but no loss of results.
2015-08-19 23:22:38
looks like you've lost some old results
the old PhaseRotEbij5a and ChicaneLinacA shows a huge dip
2015-08-21 12:35:29
Nice.  Lost 2 million points worth of results....
[Edited by [XS]riptide at 2015-08-21 12:35:53]
Stephen Brooks
2015-08-21 17:05:25
The counts won't be corrected until I install the new disk.  It shipped from NewEgg today, so that's some time next week.
2015-08-21 20:32:20
Rgr that, Stephen.  Thanks.
2015-08-25 10:58:44
The statsscript isn't getting the files from

there are files from 19-08 on mine server
Stephen Brooks
2015-08-25 17:23:13
Hopefully I should have e-mailed you about
Stephen Brooks
2015-08-26 17:14:11
OK, got results downloading off  The new hard disk is in too.
2015-11-09 09:19:00
Stats have stopped again.  I have only been crunching with a borg so my numbers are way down but not zero.
Any news on new projects? 
Stephen Brooks
2015-11-10 20:18:09
It's back online now by itself, but that's weird.  Maybe the USB drive enclosure detached?  It was doing a lot of hard disk crunching this morning - I guess it was trying to catch up.
2016-02-15 09:48:13
Hi, it seems the stats have stopped working again - mine has been saying my last contact was 17 hours ago - for the last 3-4 days
Stephen Brooks
2016-02-16 16:10:28
I think some patches got applied when I wasn't there and I got logged off, so the scripts weren't running(?) Not sure but now I'm logged in again they're working fine.  Task Scheduler says they tried to start but there was a "launch failure" whenever scripts tried to start during last weekend.
2016-05-31 13:36:48
Stats seem to be down again Stephen. 
Stephen Brooks
2016-06-01 00:11:15
Problem seems to be my workstation can't reach (but my home computer can).  The stats are running OK on the workstation itself, just not being uploaded.  I'll ask the network people about it if it's still inaccessible tomorrow.
Stephen Brooks
2016-06-02 17:10:27
I've found out that the webhost blocked the stats server (specifically) for "too many failed FTP login attempts". I'm not sure why it's failing exactly, but I could get the block lifted by logging in to the site control panel from here.

Then I need to check if the FTP sessions are really going through, or whether they've changed the login convention (*without telling me*).
2016-06-02 22:54:35
Could the failed FTP login attempts be Muon1 clients attempting to upload results to the seemingly nonexistent server, listed in servers.csv, but last recorded in my sendlog 20141104.
Stephen Brooks
2016-06-03 00:23:02
Nah it was a screw-up on the webhost end somehow - they didn't specify but after a couple of goes they fixed my FTP login.  No configuration change was required on my part, but the stats are updating again now. 
: contact : - - -
E-mail: sbstrudel
Yahoo: scrutney_mallard
Jabber: stephenbrooksstrudel
Twitter: stephenjbrooks

Site has had 15846017 accesses.