stephenbrooks.orgForumMuon1Bug Reports4.44a - nothing but errors
Username: Password:
Search site:
Subscribe to thread via RSS
2007-12-13 21:40:40
Downloaded the 4.44a The file appears not to include lattices (no big deal - I downloaded them) but no matter what I do, the client is crashing.  This is now a clean install - and still doing the same thing so I'm dead in the water.  Am I not holding my mouth right or something?
2007-12-13 21:55:30
Did you download the full version or just the upgrade version?  Just a thought...
2007-12-13 22:06:33
Tried 'em both.  I don't know if the download file changed or what.  It doesn't appear to be complete since the lattices are missing - and I'm not sure what else.  Whenever it tries to download anything - it craps itself.
2007-12-13 22:17:05
IIRC the lattices are not included ever.  thus when you start a fresh install the program downloads them from the server.  Are you running the graphical or commandline version?  Is there a point when it stalls or does it just not start up?
2007-12-13 22:28:44
hmmm... interesting.  444a includes old lattices - but no matter.  I don't think the lattices are the issue.

Tried running both in command line, and background with the same result.

The client starts - then attempts to download samplefiles / and/or lattices and the the MSFT error report dialog pops up whilst the client dies an agonizing death.

Until resolved - I've switched back to 443d and running PhaseRotEby1 so that at least I have some production.

This behavior manifested itself on two different machines in exactly the same way.
2007-12-14 12:44:47
4.44a dies occasionally also for me, always at the end of a simulation.  I'm currently investigating, so far it seems to be related to autosave.
Stephan Hermens[RKN]
2007-12-14 15:14:26
It looks like v4.44a is not running on older processors.  It works fine on my Pentium 4 and Athlon 64, but does not work on my Pentiun III and Athlon (1GHz) processor.
Stephen Brooks
2007-12-14 17:36:32
I also just found that the -2%/0Mpts bug that I thought I'd fixed has come back in 4.44a, so I'll have another go at fixing it on Monday.  Seems to do it after a certain number (11?) of simulations on my machines.
2007-12-14 18:03:48

Machine #1 is an old AMD T-bird 1.2GHz.  Machine #2 is a PIII.  Therein may lie the rub.  I've got another newer machine - I guess I could try it out on that one.  Perhaps the mystery will be solved.
Stephen Brooks
2007-12-14 19:44:15
This might be the old "optimise" switch on my compiler that I turned on.  I remember previously I had to turn it off to get stable operation.
2007-12-15 01:09:32
Zounds!  Do I sense a 4.44b release?

Stephen Brooks
2007-12-15 01:41:48
Yes, I'm now paying the price for a year of tweaking on my local machine that wasn't put through its paces by a the hundreds of DPAD users!  Until I have a credible 4.44b (early next week probably), I'm leaving the old 4.43d on the page to download.

This does have the odd effect that 4.43d users can only run PhaseRotEb1 (the -a lattices I restricted to 4.44 because the muon scores evaluate slightly differently).
: contact : - - -
E-mail: sbstrudel characterstephenbrooks.orgTwitter: stephenjbrooksMastodon: strudel charactersjbstrudel RSS feed

Site has had 25679023 accesses.