stephenbrooks.orgForumMuon1Bug ReportsProblems w/ v4.32
Username: Password:
Search site:
Subscribe to thread via RSS
thormodr
2003-09-26 19:03:51
I tried to run v4.32 but it crashes immediately.  I tried w/ and w/o the -b and -c flags. 
I am running a Win98 on AMD K6-2 500Mhz machine...
I erased the user.txt file and it doesn't get to the point of looking and complaining about the missing file.

I get the following message:

MUON1 executed an invalid instruction in
module MUON1.EXE at 0177:0040f38a.
Registers:
EAX=00000006 CS=0177 EIP=0040f38a EFLGS=00010246
EBX=0000000b SS=017f ESP=0068f7f8 EBP=0068f808
ECX=00560414 DS=017f ESI=00560414 FS=6977
EDX=0056041b ES=017f EDI=00000000 GS=0000
Bytes at CS:EIP:
0f 44 7d fc c6 04 3e 2e ff 75 0c 8d 44 37 01 50
Stack dump:
81890824 8189a564 00580000 00000006 0068f82c 0042066e 0045017d 00450ddc 81890824 8189a564 00580000 00000001 c171bfb0 0068fdb8 00425c4d 0045017

[This message was edited by thormodr on 2003-Sep-27 at 3:13.]
Boots
2003-09-27 00:45:19
Hi All, My first time doing this.  Downloaded V3.2. Lots of little problems.
On the GUI display showing Muons Retained -1.#10% and the rest -1.#J%.
When I use any of the programmed Keys F1-F12 or Space Bar programe terminates.
Had to insatall into new folder as did not work over riding V3.1c. In stats moving mouse terminates programe.  Help please!

Boots
Stephen Brooks
2003-09-27 05:40:24
Well, I've managed to replicate something like Boots's error on my Windows 98 machine: it appears to happen when you restore an autosaved file (that'll be any time you quite graphical mode and then come back in) and is probably a divide-by-zero error somewhere in the routine that generates those onscreen numbers, though it could also be related to the restoring of autosave files.
Somehow, though, you've still managed to send in some genuine-looking results to the stats database.

As for thormodr's error, solving that will have to wait until Monday when I can compile a debugging version and then you'll probably be able to tell me what line and routine it crashed in from that.

It doesn't make any sense: that's why they call it "virtual"
Boots
2003-09-27 13:08:01
Hi Stephen,
OK As you can see in stats using background.exe all works fine.  Another problem with the GUI is that out of the blue it terminates it self!  You are correct that when I restart from autosave same funny -1.#J% and not able to use any keys.

W98SE - 2.2 Intel P4 - 768 megs Asus - 3400 VC - 160 g HD.

Norman

Life the Universe and Everything!
px3
2003-09-27 23:53:30
Hi Stephen,

same problem for me using the new version on a win2k version.
The only error i get "muon1 produced errors and will be closed by windows".

An ideas ?

Regards,

PX3
[OCAU] badger
2003-09-28 22:31:45
I get:
MUON1 executed an invalid instruction in
module MUON1.EXE at 0167:0040f38a.
Registers:
EAX=00000006 CS=0167 EIP=0040f38a EFLGS=00010246
EBX=0000000b SS=016f ESP=0068f7f8 EBP=0068f808
ECX=0056043c DS=016f ESI=0056043c FS=2a57
EDX=00560443 ES=016f EDI=00000000 GS=0000
Bytes at CS:EIP:
0f 44 7d fc c6 04 3e 2e ff 75 0c 8d 44 37 01 50
Stack dump:
8171d880 8171f438 00580000 00000006 0068f82c 0042066e 0045017d 00450ddc 8171d880 8171f438 00580000 00000001 d0a29000 0068fdb8 00425c4d 0045017d

running win98se on k6-400.

I'll go back to 4.31b as I can't get it to run... even for a second

www.BadgerMotorsport.tk Proudly sponsored by GRX-Computers
Stephen Brooks
2003-09-29 03:37:06
See my post in the "General Project Forum". You can now try using v4.32a, and if that doesn't work, the debugging version of it.

It doesn't make any sense: that's why they call it "virtual"
[OCAU] badger
2003-09-29 18:17:23
ok I got 4.32b, and tried it, same sort of error. 

(BTW I have 4.32 runnig fine on Win XP and Win2k server)

I tried the debugging version - this is the error message:

lcc runtime: GP fault.  Stack trace

0 setextension [6] d:\sjb39\muon1\muon1.c 64
1 readconfigfile [3] d:\ssjb39\muon1\muon1.c 6
2 SBCLIB_main2 [11] d:\ssjb39\muon1\muon1.c 61
3 WinMain [0] d:\ssjb39\muon1\muon1.c 50

Current instruction: 0x414c3a

any help

www.BadgerMotorsport.tk Proudly sponsored by GRX-Computers
thormodr
2003-09-29 20:31:47
I ran the debugging version and got the same as Badger above...
Stephen Brooks
2003-09-30 05:03:57
Okay, that's a strange place to have a crash.  The line actually reads "if (n==0) n=i;" - no array access or anything to do with memory, just an operation on local variables!!
Here is another debug version that should spit out a file "debug.txt" just before the crash occurs.  If you could post what this file contains it would be interesting.

It doesn't make any sense: that's why they call it "virtual"
thormodr
2003-09-30 10:45:12
I tried v4.32b on an Intel machine w/ Win98 at work and it worked.  It would appear to be something w/ the AMD K6/K6-2 line of processors...
thormodr
2003-09-30 17:20:16
When I run the debug version, the resultant debug.txt file reads the following:

----- setextension(0045018E:config,00450E01:txt) -----
ret=005604A8:config i=6
n=0 i=6


Hope this helps...

Granted the biggest help would be to toss the machine out the windows buy something more up to date...
[OCAU] badger
2003-09-30 18:50:53
I get the same:
----- setextension(0045018E:config,00450E01:txt) -----
ret=00560460:config i=6
n=0 i=6

I haven't yet tried it on my p2 with win98.

www.BadgerMotorsport.tk Proudly sponsored by GRX-Computers
Boots
2003-10-18 20:27:30
Stephen, Hoping you had a nice weekend!
I downloaded V432d, placed into new folder run muon1.exe received the following.

MUON1 caused an invalid page fault in
module MUON1.EXE at 017f:0040c22c.
Registers:
EAX=005603c0 CS=017f EIP=0040c22c EFLGS=00010246
EBX=00000000 SS=0187 ESP=0068ee90 EBP=0068f294
ECX=00000000 DS=0187 ESI=0068f2e8 FS=988f
EDX=0046003c ES=0187 EDI=00000000 GS=0000
Bytes at CS:EIP:
8b 3c 9f 89 fe 81 c6 08 08 00 00 83 ec 1c 89 e7
Stack dump:
0068f2b8 0068f2e8 0043b200 00000000 00000000 00000000 ffff037f ffff4000 ffffffff 004278e0 070c017f 0068f228 ffff0187 00000000 00000000 00000000

Did not matter what I did same result.  Noticed that the software did not ask me for a user name like before.  So I then placed a copy of user.txt file into folder all works fine now.
Just info for you.



Life the Universe and Everything!
Boots
2003-10-19 00:45:41
Another observation, plus problem.
If running GUI in Win98se at the end of processing, programme terminates, able to restart, does process though terminates each time.  While processing I observe MAX Z distance = anything from -13.321 to 17.388 eg -2.318 11.034 5.234 -10.213 etc and now and again shows -1#10. MAX Z % all over the place.  Is this correct?
When running the Muon1_cmdline.bat file after processing I receive a notice FATAL sample 100.txt do not have this file, and then shuts down.  Unable to run GUI though cmdline at this time is working OK.
Hope this helps!

Life the Universe and Everything!
Stephen Brooks
2003-10-19 12:42:10
Looks like I might need to have another look at what happens when user.txt doesn't exist.  The GUI bug you mentioned (bad Z statistic reporting) is quite possible given I changed around the particle-beam structure a few weeks ago.  But:
quote:
Originally posted by Boots:
When running the Muon1_cmdline.bat file after processing I receive a notice FATAL sample 100.txt do not have this file, and then shuts down.
I'd like a screenshot or the literal text of what the window said for this one.  If you've put "sample100.txt" inside the "lattices" directory then this is caused by that error.

It doesn't make any sense: that's why they call it "virtual"
Boots
2003-10-19 22:44:45
I'm happy so say, you're correct.  I had placed the Sample100.txt file into folder Lattices.  I was going to copy and paste into new Results.dat when I had completed the next upload.  Removed file, all is working correctly now other than the problem re user.txt file.
I thank you.
PS How do I send the screen shot, you requested.  Pasted into a WordPad?
Boots

Life the Universe and Everything!
: contact : - - -
E-mail: sbstrudel characterstephenbrooks.orgTwitter: stephenjbrooksMastodon: strudel charactersjbstrudel charactermstdn.io

Site has had 17456186 accesses.