stephenbrooks.orgForumMuon1Bug ReportsSetting client priority
Username: Password:
Search site:
Subscribe to thread via RSS
kitsura
2004-03-18 05:51:30
Not sure if this constitutes as a bug but I'm unable to set the program priority for the muon client in the task manager as it will always go back to normal priority after one simulation is completed.  This wasn't a problem in the previous version of the client.
Stephen Brooks
2004-03-18 06:29:47
That's because it re-reads config.txt at the beginning of each simulation and sets the priority from the option in there.  N = Normal, L = Lower and B = Background, which ought to be as low as you want it to go.
kitsura
2004-03-18 14:48:54
So is there no way to set it to high?
[DPC]Stephan202
2004-03-19 00:11:52
quote:
Originally posted by kitsura:
So is there no way to set it to high? 

Apperantly not.
Besides, there's no reason to set the priority to high.  It can make your computer nearly uncontrolable, and the client will take as much as it can anyway.  The only difference is that background processes will have a harder time getting cycles when you set DPAD's priority to high.  I doubt that that's either making a noticable differnce or is desirale in any other way.
Stephen Brooks
2004-10-18 02:43:27
No idea what's going on here - task manager shows Low and Normal priorities OK, but does not show "Below normal".

[update] OK, it looks like the "Above Normal" and "Below Normal" that Task Manager in 2000 and XP shows are new levels that were only introduced in 2000 and above.  If I make Muon1 use them, it would be incompatible with 95,98,Me and NT (see note on this page).  So I've got to keep it how it is, which _does_ set the priorities sensibly, though the 'L'ow mode appears as "Normal" in Task Manager since there it is the _thread_ priority that is being lowered not the process...
kitsura
2004-10-18 14:53:05
Wow that was a fast response Razz

I was talking about the setting the process priority rather than the thread one.  Even if I manually change it after 1 result is generated the priority will go back to normal.
Stephen Brooks
2004-10-19 03:35:45
Yes, I know.  That's because at the start of the simulation it sets the priority from config.txt, so you need to choose what priority you want in there.
HETTATLONGUN
2004-10-23 11:43:51
Yep!  Smile

I always set priority to [B]ackground.  That way, when Windows wants to do some housekeeping chore, it can do so without interfering with the muon1 program.

If you look at Task Manager, CPU Usage, regardless of the priority, the muon1.exe will get most of the CPU Usage, in terms of time.
Stephen Brooks
2004-10-23 16:11:49
I personally set it on [L]ow since this is a couple of points below every other normal app.  I might be using, but it's well above things like the screensaver.  However, I think WinRAR goes on some low-ish priority too, so I've occasionally had it going really slow when Muon1_background is at [L]ow.
: contact : - - -
E-mail: sbstrudel characterstephenbrooks.orgTwitter: stephenjbrooksMastodon: strudel charactersjbstrudel charactermstdn.io

Site has had 17082684 accesses.