stephenbrooks.orgForumMuon1Bug ReportsNumber of Decays for SoleniodsTo15cm in v4.4
Username: Password:
Search site:
Subscribe to thread via RSS
Stephan Hermens[RKN]
2004-05-20 09:14:21
Hello.

The current version 4.4 seems to calculate 10 decays, when the first new simulation after a start of the program is SoleniodsTo15cm.  After one of the other designs was calculated only 3 decays seem to be done also for SoleniodsTo15cm.
This looks like a bug to me.

And why are the parameters Z and RodAngle for the tantalum rod fixed in Phase Rot and free in ChicaneLinac?
Stephen Brooks
2004-05-20 11:39:27
quote:
Originally posted by Stephan Hermens[RKN]:
The current version 4.4 seems to calculate 10 decays, when the first new simulation after a start of the program is SoleniodsTo15cm.  After one of the other designs was calculated only 3 decays seem to be done also for SoleniodsTo15cm.
This looks like a bug to me. 
Yes, I think I forgot to set a default for it and the variable just continued on in its old setting.  It doesn't totally invalidate the results, just changes their variance, but I'll fix it in v4.41.
quote:
And why are the parameters Z and RodAngle for the tantalum rod fixed in Phase Rot and free in ChicaneLinac? 
Hmm, well spotted!  I cut and paste the parts of the accelerator from the decay channel file and then added bits.  I did check over the lattices before sending them out, but that's the 2nd bug in these ...A ones.  Perhaps the 'A' should stand for 'alpha version'... I can now solve those in the ...B bugfix which I'm having to do anyway.
: contact : - - -
E-mail: sbstrudel characterstephenbrooks.orgTwitter: stephenjbrooksMastodon: strudel charactersjbstrudel charactermstdn.io

Site has had 16975730 accesses.